Back to overview
Degraded
BRAVO Payments
Mar 23, 2026 at 05:56pm UTC
Affected services
Payments and Billing
Resolved
Mar 27, 2026 at 09:56am UTC
We've now identified the issue with Bravo payments. A patch has now been deployed to resolve it, and currently monitoring it. Should you still encounter any problems, please do not hesitate to contact us.
Affected services
Created
Mar 23, 2026 at 05:56pm UTC
We are aware of some reports regarding payments made via Bravo requiring manual review. If you encounter an issue with a Bravo payment not being reflected on an invoice, please do not hesitate to contact us, and we'll look into it for you.
Affected services